네트워크 구축 – Vlan 과 정적 라우팅

사용자 삽입 이미지
1) Vlan

<시작하기전에>
 – Switch끼리는 Ethernet Port 11,12번으로 연결합니다.
 – PC는 Port 1번부터 연결합니다.
 – 각 스위치 별로 이름을 정해줍니다.
  Switch>en
  Switch#conf t
  Enter configuration commands, one per line.  End with CNTL/Z.
  Switch(config)#hostname [이름]
   * 편의상 [이름]에 SW1/SW2/SW3 으로 설정을 합니다.
 – vlan 100 은 PC1, PC4, PC7 이 연결됩니다.
 – vlan 200 은 PC2, PC5, PC8 이 연결됩니다.
 – vlan 300 은 PC3, PC6, PC9 이 연결됩니다.
 – vlan 100 은 192.168.10.1 ~ 3 ip 설정  ( Subnet Mask : 255.255.255.0  /  Default Gateway : 192.168.10.1 )
 – vlan 200 은 192.168.20.1 ~ 3 ip 설정  ( Subnet Mask : 255.255.255.0  /  Default Gateway : 192.168.20.1 )
 – vlan 300 은 192.168.30.1 ~ 3 ip 설정  ( Subnet Mask : 255.255.255.0  /  Default Gateway : 192.168.30.1 )

1. vlan 정보를 송/수신을 하기 위해 Ethernet 모드를 변경합니다. ( SW1/SW2/SW3 모두 적용필요 !! )
  – PC가 연결된 포트는 Access 모드 설정
SW1(config)#interface range fa0/1 – 10
SW1(config-if)#switchport mode access
SW1(config-if)#exit

  – Switch끼리 연결된 포트는 Trunk 모드 설정
SW1(config)#interface range fa0/11 – 12
SW1(config-if)#switchport mode trunk
SW1(config-if)#exit

2. VTP 도메인을 설정합니다. ( SW1/SW2/SW3 모두 적용필요 !! )
SW1(config)#vtp domain [이름]
* 편의상 kimtree 를 설정합니다.

3. VTP 모드를 설정해 줍니다. ( Switch별 적용 옵션이 다르니 확인 필요 !! )
SW1(config)#vtp mode server  (SW1의 경우 – 모든 Vlan 정보를 제공하는 서버가 됩니다. )
SW2(config)#vtp mode client   (SW2/SW3의 경우 – Vlan 정보를 수신하는 클라이언트가 됩니다. )

4. Vlan을 추가합니다. ( SW1 에서만 작업하는 옵션 )
SW1#vlan database
SW1(vlan)#vlan 100
SW1(vlan)#vlan 200
SW1(vlan)#vlan 300

5. 포트마다 Vlan을 설정해 줍니다. ( SW1 에서만 작업하는 옵션 )
SW1(config)#interface fa0/1
SW1(config-if)#switchport access vlan 100
SW1(config-if)#exit

SW1(config)#interface fa0/2
SW1(config-if)#switchport access vlan 200
SW1(config-if)#exit

SW1(config)#interface fa0/3
SW1(config-if)#switchport access vlan 300
SW1(config-if)#exit

@ 점검하기 ( vlan 등록여부와 포트 할당 여부를 확인합니다. )
SW1#sh vlan

== Switch의 모든 설정은 여기가 끝입니다.

6. PC마다 ip를 셋팅해 줍니다.
(PC1, PC4, PC7 경우 – vlan100 )
ipconfig /ip 192.168.10.x 255.255.255.0   ( x 는 1~3 까지 차례대로 사용합니다. )
ipconfig /dg 192.168.10.1

(PC2, PC5, PC8 경우 – vlan200 )
ipconfig /ip 192.168.20.x 255.255.255.0   ( x 는 1~3 까지 차례대로 사용합니다. )
ipconfig /dg 192.168.20.1

(PC3, PC6, PC9 경우 – vlan300 )
ipconfig /ip 192.168.30.x 255.255.255.0   ( x 는 1~3 까지 차례대로 사용합니다. )
ipconfig /dg 192.168.30.1

7. 마지막으로 ping 으로 정상적으로 통신이 되는지 확인합니다.
(PC1, PC4, PC7 경우 – vlan100 )
ping 192.168.10.1 ~ 3  경우 -> 정상적 통신
그외 -> Request Time Out 이 나와야 정상적입니다.

(PC2, PC5, PC8 경우 – vlan200 )
ping 192.168.20.1 ~ 3  경우 -> 정상적 통신
그외 -> Request Time Out 이 나와야 정상적입니다.

(PC3, PC6, PC9 경우 – vlan300 )
ping 192.168.30.1 ~ 3  경우 -> 정상적 통신
그외 -> Request Time Out 이 나와야 정상적입니다.

사용자 삽입 이미지


2) 정적 라우팅

<시작하기전에>
 – Router 끼리는 Serial 0번으로 연결합니다. DCE장비는 Router 1으로 합니다.
 – PC는 Port 1번부터 연결합니다.
 – 각 스위치 별로 이름을 정해줍니다.
  Switch>en
  Switch#conf t
  Enter configuration commands, one per line.  End with CNTL/Z.
  Switch(config)#hostname [이름]
   * 편의상 [이름]에 SW1/SW2 으로 설정을 합니다.
– 각 라우터 별로 이름을 정해줍니다.
  Router>en
  Router#conf t
  Enter configuration commands, one per line.  End with CNTL/Z.
  Router(config)#hostname [이름]
   * 편의상 [이름]에 R1/R2 으로 설정을 합니다.

 – PC1/PC2 192.168.1.2 ~ 3
 – PC3/PC4 192.168.2.2 ~ 3
 – Router1-S0  192.168.99.1
 – Router1-E0  192.168.1.1
 – Router2-S0  192.168.99.2
 – Router2-E0  192.168.2.1

1. Ethernet 구간 ip 입력하기
( R1 의 경우 )
R1(config)#interface FastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

( R2 의 경우 )
R2(config)#interface FastEthernet 0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

2. Serial 구간 ip 입력하기
( R1 의 경우 )
R1(config)#int Serial 0
R1(config-if)#ip address 192.168.99.1 255.255.255.0
R1(config-if)#clock rate 72000 ( DCE 장비일 경우에만 입력 )
R1(config-if)#no sh
( R2 의 경우 )
R2(config)#int Serial 0
R2(config-if)#ip address 192.168.99.2 255.255.255.0
R2(config-if)#no sh

3. ping으로 상대방 시리얼포트에 ping 날리기
R1#ping 192.168.99.2
R2#ping 192.168.99.1

==성공시메세지=======================================================
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
=====================================================================
==실패시메세지=======================================================
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5), round-trip min/avg/max = 1/2/4 ms
=====================================================================

4. 정적 라우팅 설정하기 ( R1 -> R2 일때 라우팅 경로 설정 )
R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.99.2
                 상대방 2번 네트워크/서브넷마스크/상대방 시리얼 포트
R1(config)#exit

3번과 같이 ping을 날렸을때 성공하면 제대로 설정이 된것이다.

@ 점검하기 ( 정적 ip Route 경로 여부 확인하기 )
SW1#sh ip rou

5. 정적 라우팅 해제하기
R1(config)#no ip route 192.168.2.0 255.255.255.0 192.168.99.2
R1(config)#exit
또는
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.99.2
R1(config)#exit


사용자 삽입 이미지
3) 정적 라우팅 2 – 라우터 여러개  

<시작하기전에>
 – DCE장비는 Router 1/Router 3으로 합니다.
 – 각 라우터 별로 이름을 정해줍니다.
  Router>en
  Router#conf t
  Enter configuration commands, one per line.  End with CNTL/Z.
  Router(config)#hostname [이름]
   * 편의상 [이름]에 R1/R2/R3/R4 으로 설정을 합니다.

 – Router1-S0 <-> Router2-S0    192.168.60.0 네트워크
 – Router1-S1 <-> Router4-S0    192.168.50.0 네트워크
 – Router2-S1 <-> Router3-S0    192.168.70.0 네트워크

 – Router1-S0  192.168.60.1
 – Router1-S1 192.168.50.2
 – Router1-E0 192.168.10.0  네트워크

 – Router2-S0  192.168.60.2
 – Router2-S1 192.168.70.1
 – Router2-E0 192.168.20.0  네트워크

 – Router3-S0  192.168.70.2
 – Router3-E0 192.168.30.0  네트워크

 – Router4-S0 192.168.50.1
 – Router4-E0 192.168.40.0  네트워크

1. 각 포트 아이피 설정하기  ( R1/R2/R3/R4 별로 위에 나온 아이피 대입 )
Router#en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int s0
Router(config-if)#ip address [라우터 S0구간 아이피] 255.255.255.0
Router(config-if)#clock rate 72000 ( DCE장비의 시리얼 구간일경우 )
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int s1
Router(config-if)#ip address [라우터 S1구간 아이피] 255.255.255.0
Router(config-if)#clock rate 72000 ( DCE장비의 시리얼 구간일경우 )
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip add [라우터 E0구간 아이피]  255.255.255.0
Router(config-if)#no sh

2. 라우팅 하기

Router(config)#ip route [ 목적지 네트워크 주소 ] [ 서브넷 마스크 ] [ 시리얼 구간 – 상대방 라우터 시리얼 ]
  예) R1 라우터 설정
Router(config)#ip route 192.168.40.0 255.255.255.0 192.168.50.1
Router(config)#ip route 192.168.20.0 255.255.255.0 192.168.60.2
Router(config)#ip route 192.168.70.0 255.255.255.0 192.168.60.2
Router(config)#ip route 192.168.30.0 255.255.255.0 192.168.60.2

3. 라우팅 테이블 확인하기
 – 각 라우터에서 Router#sh run 으로 확인한다.

4. 다른 네트워크에 ping 날리기
Router#ping [ ip 주소 ]

==성공시메세지=======================================================
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to [ ip 주소 ], timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
=====================================================================
==실패시메세지=======================================================
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to [ ip 주소 ], timeout is 2 seconds:
…..
Success rate is 0 percent (0/5), round-trip min/avg/max = 1/2/4 ms
=====================================================================

jk3.hwp
jk2.topik5.topik4.top

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다